signalement de bug

+3 votes
373 vues
question 8 Juillet 15 dans Utilisation du site par paco (436 points)  
il y a un bug quand on répond à une question qui contient une parenthèse. Rattrappage de la librairie mathjax dans question.js . Il faut tester e avant de lui assigner un innerhtml ou bien améliorer la détection de formules ... Ou alors charger mathjax qui ne sert à rien ici. Ou alors retirer le bouton en option ...
commentée 8 Juillet 15 par ladmin (2,246 points)  
merci. En effet, j'ai repris un patch réputé fiable sans même le tester quand il n'y a pas mathjax.
commentée 8 Juillet 15 par ladmin (2,246 points)  
j'ai retiré le patch quand il y a une condition d'erreur. Merci @Paco
commentée 8 Juillet 15 par jarda (249 points)  
@ladmin: je fais un test aussi
commentée 8 Juillet 15 par ladmin (2,246 points)  
merci @jarda. J'ai fini par comprendre. Le patch est mal fouttu mais il va falloir plonger dans la doc de mathjax ... Le pb est maintenant réduit au non affichage la première fois des formules. La réponse est créée dans un div non repéré par le convertisseur de mathjax. Quand elle est modifiée ou revue , tout se passe bien.
commentée 8 Juillet 15 par ladmin (2,246 points)  
bug entièrement corrigé et compatible avec les variantes sans mathjax. Merci à tous
commentée 8 Juillet 15 par anvers (269 points)  
plus fort que le SAV, bravo !

Se connecter ou S'inscrire pour répondre à cette question.

Feel free to ask and answer in english

Bienvenue sur les FAQ de 123.fr, posez vos questions ou répondez à celles des autres usagers.

...