pourquoi mysql 5.6 et non 5.7 ? apache 2.2 et non 2.4 ?

0 votes
558 vues
question 6 Janvier 17 dans Tous les CMS par atlas (293 points)  
recatégorisées 6 Janvier 17 par atlas
Pourquoi faire la migration 5.5 vers 5.6 puis ensuite 5.6 vers 5.7 ? vu ce que c'est difficile à chaque fois, on pourrait sauter directement à la dernière version, non ?

Pareil pour Apache
commentée 6 Janvier 17 par ladmin (2,246 points)  
et pourquoi apache 2.2 au lieu de 2.4 tant qu'on y est ...
commentée 6 Janvier 17 par atlas (293 points)  
en effet ... pourquoi ne pas utiliserr la dernières versions ?
commentée 6 Janvier 17 par atlas (293 points)  
j'ai édité la question pour Apache
commentée 6 Janvier 17 par ladmin (2,246 points)  
+1 pour l'effort ...
commentée 6 Janvier 17 par debo (228 points)  
Quand golf a parlé de la version de php, il a pris -3. Faudrait savoir ...

1 Réponse

+1 vote
réponse 6 Janvier 17 par ladmin (2,246 points)  
editée 14 Octobre 17 par ladmin

Mysql 5.6 n'est pas moins sécurisé que 5.7.

Mais la dernière version de 5.6 traite de 10 à 15% plus de requêtes à la seconde que la dernière version de 5.7.. Elle est aussi plus rapide que toutes les versions de mariadb. Ce dernier n'a toujours pas résolu quelques problèmes de lenteur dans un cas spécifique mais qui survient beaucoup en hébergement. On peut aussi considérer mariadb comme une autre version de mysql.

Et non, il n'y a pas de véritable migration à effectuer puisque le sql est strictement compatible avec la version précédente.

Pareil pour Apache 2.2 qui est notre choix quand il y a php, sinon on installe 2.4. Certes, il consomme un petit rien de mémoire en plus mais il est aussi sécurisé ( après nos patchs ) et il tourne php 10% plus vite.

Ces serveurs et language ont tous des versions expérimentales très avancées. Nous les testons aussi. Mais avant d'arriver en production , il vaut mieux assurer comme le font php 5.6, mysql 5.6 et apache 2.2 ( tous patchés pour éviter les embrouilles entre voisins )

Vous avez peut être noté le doublement de vitesse sql dans le passage de 5.5 à 5.6. Ce n'est pas qu'une histoire de version : il y a plus de ram et bogomips, une config de base trouvée après des centaines d'essais, notre module de reconfiguration dynamique et bien sûr 5.6

EDIT : c'était la réponse en janvier, depuis les choses se sont arrangées. Les migrations sont transparentes et progressives. Un petit stress à venir peut-être avec php 7.2 mais un kit de compatibilité totale est annoncé.

commentée 6 Janvier 17 par ladmin (2,246 points)  
Ce qu'on entend au bar en fin de soirée : il y a une superstition chez les éditeurs autour des valeurs 5.6 et avant 6.0 , tant Il y a eu d'étoiles éteintes après le passage en 6. C'est peut être pour cela qu'on va passer ensuite directement à 7 voire à 8 ... Une bien curieuse façon d'appréhender la notion d'usure. Sql n'a pas beaucoup bougé depuis 30 ans et presque personne ne sait utiliser correctement TokuDB.
commentée 6 Janvier 17 par atlas (293 points)  
ok, merci ...
Feel free to ask and answer in english

Bienvenue sur les FAQ de 123.fr, posez vos questions ou répondez à celles des autres usagers.

...